schließen

Loginbox

Trage bitte in die nachfolgenden Felder Deinen Benutzernamen und Kennwort ein, um Dich einzuloggen.


  • Username:
  • Passwort:
  •  
  • Bei jedem Besuch automatisch einloggen.


  •  
   

Avatar hochladen geht nicht



WernerD offline
Benutzer
Avatar
Ort:   Ulm
Beiträge: 15 seit: 02 / 2014
Private Nachricht
Betreff: Avatar hochladen geht nicht  -  Gepostet: 20.02.2014 - 01:37 Uhr  -  
Hallo Freunde,

wenn ich die Seite usercp.php?mode=avatar aufrufe, dann sind die Felder "Bild hochladen: Durchsuchen" bei Avatar und bei Userbild beide tot, sie reagieren auf nichts. Wo und wie kann ich einen Avatar hochladen?
Viele Grüße, Werner
nach unten nach oben
Raimund Sichmann offline
Benutzer
Avatar
Ort:  
Beiträge: 7356 seit: 08 / 2002
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 20.02.2014 - 21:40 Uhr  -  
Hallo Werner,
hast du ein "Antiscripting-Tool" laufen? Viele Komfortfunktionen gehen nur, wenn Javascript o.ä. erlaubt ist.

Gruß
Raimund
nach unten nach oben
WernerD offline
Benutzer
Avatar
Ort:   Ulm
Beiträge: 15 seit: 02 / 2014
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 20.02.2014 - 22:09 Uhr  -  
Hallo Raimund,

Zitat geschrieben von Raimund Sichmann
hast du ein "Antiscripting-Tool" laufen? Viele Komfortfunktionen gehen nur, wenn Javascript o.ä. erlaubt ist.

Das habe ich selbstverständlich beachtet. Ich habe Noscript laufen und relativ scharf eingestellt. Ich geben dann Seiten gezielt von Hand frei. "onlinebanking-forum.de" habe natürlich sofort freigegeben, die üblichen Werbe- und Statistikseiten normal nicht. Aber auch "Temporär alle Beschränkungen für diese Seite aufgeben" hatte nichts gebracht. Es war wirklich alles freigegeben. Daran liegt es vermutlich nicht, oder doch? Wo kann ich noch suchen?
Viele Grüße, Werner
nach unten nach oben
onlbanker offline
Benutzer
Avatar
Ort:  
Beiträge: 3335 seit: 05 / 2013
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 21.02.2014 - 08:10 Uhr  -  
Welchen Browser nutzt du? Versuch doch mal einen anderen "nackten" ohne jegliche Tools und Plugins.
nach unten nach oben
Raimund Sichmann offline
Benutzer
Avatar
Ort:  
Beiträge: 7356 seit: 08 / 2002
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 21.02.2014 - 08:45 Uhr  -  
Hallo Werner,
eventuell muss man sich nach dem Entschärfen auch neu anmelden und die Seite neu laden, damit die Scriptpakete neu initialisiert werden.
Versuch es bitte noch einmal, bevor ich mich an den Entwickler wende.

Gruß
Raimund
nach unten nach oben
WernerD offline
Benutzer
Avatar
Ort:   Ulm
Beiträge: 15 seit: 02 / 2014
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 21.02.2014 - 11:19 Uhr  -  
Hallo Raimund und Onlbanker,

Zitat
Welchen Browser nutzt du? Versuch doch mal einen anderen "nackten" ohne jegliche Tools und Plugins.

Ich benutze stets den aktuellen Firefox unter Windows XP. Ich habe den FF auch im abgesicherten Modus aufgerufen, also alle Plugins deaktiviert: keine Änderung.

Zitat geschrieben von Raimund Sichmann
eventuell muss man sich nach dem Entschärfen auch neu anmelden

Meinst Du jetzt das Forum oder Firefox? Ich habe beides gemacht. Derzeit ist freigegeben "onlinebanking-forum.de". Gesperrt ist "ip2info.org". Lertzteres habe ich jetzt auch noch temporär freigegeben, worauf alle betroffenen Seiten - interessanterweise nicht die vom Onlinebanking-forum - neu geladen wurden.

Zitat
und die Seite neu laden, damit die Scriptpakete neu initialisiert werden.

Das ist ja oft genug passiert. In der Zwischenzeit wurde auch der Rechner mehrfach abgeschaltet und neu hochgefahren. Wo kann ich noch nachsehen? Was könnte noch stören? Es laufen noch Adblock Plus, Flashblock, Ghostery, Perspectives, Refcontrol und WOT und weitere, die sicher keinen Einfluss haben. Aber wie gesagt, auch ganz ohne Erweiterungen ging es nicht.
Viele Grüße, Werner
nach unten nach oben
onlbanker offline
Benutzer
Avatar
Ort:  
Beiträge: 3335 seit: 05 / 2013
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 21.02.2014 - 12:04 Uhr  -  
Werner, versuch es doch einfach mal mit dem Internet Explorer. Selbst mit der 8er Version sollte das funktionieren.

Raimund, einen Entwickler brauchts dafür nicht, das liegt nicht am Forum.
nach unten nach oben
msa offline
Benutzer
Avatar
Ort:   München
Beiträge: 3733 seit: 03 / 2007
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 21.02.2014 - 13:07 Uhr  -  
Ich verwende auch Firefox mit AdblockPlus und NoScript mit halbwegs moderaten Einstellungen, und da würde das Hochladen gehen. Habs gerade ausprobiert.
nach unten nach oben
WernerD offline
Benutzer
Avatar
Ort:   Ulm
Beiträge: 15 seit: 02 / 2014
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 22.02.2014 - 02:32 Uhr  -  
Hallo onlbanker,

Zitat geschrieben von onlbanker
Werner, versuch es doch einfach mal mit dem Internet Explorer.

Ja, mit dem hat es geklappt. Danke sehr. Dabei ist mir aber ein Unterschied aufgefallen. Im FF habe ich nur jeweils den Knopf "Durchsuchen...", beim IE war davor noch ein Eingabefeld für den Namen. Das fejlt beim FF.

Zitat
einen Entwickler brauchts dafür nicht, das liegt nicht am Forum.

Da wäre ich mir nicht so sicher. Denn ansonsten funktionieren bei mir alle Webseiten, wenn ich sie und gegebenenfalls deren Hilfsseiten freigebe. Vermutlich kommen da mehrere Faktoren zusammen. Jeder macht einzeln nichts aus, deren Kombination bewirkt aber den Fehler. Da fällt mir ein Grundsatz der Kommunikation ein: "Halte Dich beim Senden so genau wie möglich an die Regeln und lasse beim Empfangen alles zu, was halbwegs sinnvoll interpretierbar ist." Wenn man sich nicht daran hält, funktioniert es zwar in vielen Fällen aber eben nicht in allen.

Zitat geschrieben von msa
Ich verwende auch Firefox mit AdblockPlus und NoScript mit halbwegs moderaten Einstellungen, und da würde das Hochladen gehen.

Selbst wenn ich (temporär) alle Einschränkungen für diese Seite aufhebe, geht es bei mir nicht. Da würde mich schon interessieren, wo es klemmt und wie weit es an mir und wie weit es am Forum liegt..
Viele Grüße, Werner
nach unten nach oben
infoman offline
Benutzer
Avatar
Ort:  
Beiträge: 3148 seit: 06 / 2008
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 22.02.2014 - 08:30 Uhr  -  
in der heutigen Zeit interessiert die Lösung/Ziel, nicht der Weg (oder das warum).
nach unten nach oben
onlbanker offline
Benutzer
Avatar
Ort:  
Beiträge: 3335 seit: 05 / 2013
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 22.02.2014 - 08:31 Uhr  -  
Am Forum liegt es nicht. Sonst hätte es auch längst viele mehr Reklamationen geben müssen, nicht nur von hier. Deaktiviere mal schrittweise ein Add-on nach dem anderen. Irgendwann wird es funktionieren und du wirst wissen, welches Add-on maßgeblich blockiert.
nach unten nach oben
Raimund Sichmann offline
Benutzer
Avatar
Ort:  
Beiträge: 7356 seit: 08 / 2002
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 22.02.2014 - 14:28 Uhr  -  
Zitat
Selbst wenn ich (temporär) alle Einschränkungen für diese Seite aufhebe, geht es bei mir nicht. Da würde mich schon interessieren, wo es klemmt und wie weit es an mir und wie weit es am Forum liegt..
starte den Fuchs mal mit gedrückter Shift-Taste und versuch es dann noch einmal. Die Erweiterungen sollten dann nicht aktiv sein.
Gruß
Raimund
Dieser Post wurde 1 mal bearbeitet. Letzte Editierung: 22.02.2014 - 14:28 Uhr von Raimund Sichmann.
nach unten nach oben
WernerD offline
Benutzer
Avatar
Ort:   Ulm
Beiträge: 15 seit: 02 / 2014
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 22.02.2014 - 23:34 Uhr  -  
Hallo onlbanker und Raimund,

Zitat geschrieben von onlbanker
Am Forum liegt es nicht. Sonst hätte es auch längst viele mehr Reklamationen geben müssen, nicht nur von hier.

Nu ja, wie gesagt vermute ich, dass mehrere Ursachen zusammenkommen. Eine Ursache alle bewirkt noch keinen Fehler. Erst wenn alle Usachen zusammenkommen, tritt der Fehler auf. Sehr wahrscheinlich ist bei mir etwas ungünstig eingestellt. Das alleine macht noch nichts, da ich ja mit anderen Webseiten keine Probleme habe. Vermutlich hat aber auch die Forensoftware eine Schwachstelle. Sie alleine macht auch nichts, weil ja bei den meisten anderen Benutzern dieses Forums keine Probleme auftreten. Aber beides zusammen bewirkt den Fehler.

Zitat geschrieben von onlbanker
Deaktiviere mal schrittweise ein Add-on nach dem anderen. Irgendwann wird es funktionieren und du wirst wissen, welches Add-on maßgeblich blockiert.

Zitat geschrieben von Raimund Sichmann
starte den Fuchs mal mit gedrückter Shift-Taste und versuch es dann noch einmal. Die Erweiterungen sollten dann nicht aktiv sein.

Wie ich schon in Mail 6 schrieb "Ich habe den FF auch im abgesicherten Modus aufgerufen, also alle Plugins deaktiviert: keine Änderung.". Also das ist es auch nicht. Mit IE dagegen hat es funktioniert.

Zitat geschrieben von infoman
in der heutigen Zeit interessiert die Lösung/Ziel, nicht der Weg (oder das warum).

Was soll "heutige Zeit" heißen? Gründlich zu arbeiten und dem Fehler auf den Grund zu gehen, ist nie unmodern. Nur so kannst Du Fehler künftig vermeiden. Wenn es plötzlich geht und keiner kann sagen warum, ist genau so unbefriedigend als wenn es nicht geht und keiner kann den Fehler erkennen.
Viele Grüße, Werner
nach unten nach oben
onlbanker offline
Benutzer
Avatar
Ort:  
Beiträge: 3335 seit: 05 / 2013
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 23.02.2014 - 08:14 Uhr  -  
Zitat geschrieben von WernerD
Vermutlich hat aber auch die Forensoftware eine Schwachstelle.

HTML kann valide oder nicht valide sein. Wenn es nicht valide ist, reagieren Browser unterschiedlich, weil es für invalides HTML keine Specs gibt.
Und in der Tat hat die Seite mit dem Avatar Upload einen Fehler ziemlich weit oben:
Code
<link rel="icon" href="favicon.gif" type=image/gif" />

Da fehlt ein Anführungszeichen. Raimund, das könnte man bei Gelegenheit mal mit niedriger Prio an den Hersteller melden.
Das führt aber in keinem Browser zu einem nicht funktionsfähigen Dateifeld im Forumlar.
Also am Forum kann ich keine "Schwachstelle" finden die Grund für die Fehlfunktion sein könnte.
nach unten nach oben
infoman offline
Benutzer
Avatar
Ort:  
Beiträge: 3148 seit: 06 / 2008
Private Nachricht
Betreff: Re: Avatar hochladen geht nicht  -  Gepostet: 23.02.2014 - 09:59 Uhr  -  
Zitat geschrieben von WernerD
Gründlich zu arbeiten und dem Fehler auf den Grund zu gehen, ist nie unmodern. Nur so kannst Du Fehler künftig vermeiden.

jein, denn es handelt sich bisher um ein individuelles Problem und kein grundsätzliches (=sprich wo alle User betroffen sind).
Dh. es kann durchaus sein, dass dein System (bzw. Benutzer-Profil des OS o. Browsers*) o.ä. einen "hau" Weg hat - warum soll man hier stundenlang nach der Problematik suchen?
zumal du XP einsetzt und in den nächsten Wochen sowieso das OS umstellen solltest, ua. aus Sicherheitsgründen.

wie in unserem anderen (gemeinsamen) T., hättest du dort schnell (sofort) die Lösung gehabt, wenn du meinen Empfehlungen gleich gefolgt wärst. (so hat es sich dann doch hingezogen)
wenn man diesen T. hier nimmt, sind einige User damit beschäftigt und zieht somit "Manpower" für andere User mit richtigen Problemen ab.

*= http://support.mozilla.org/de/...d-loeschen bzw. https://support.mozilla.org/de...ach-loesen
nach unten nach oben
 



Registrierte in diesem Topic
Aktuell kein registrierter in diesem Bereich

Cookies von diesem Forum entfernen  •  FAQ / Hilfe  •  Teamseite  •  Impressum   |  Aktuelle Ortszeit: 23.01.2018 - 14:55