schließen

Loginbox

Trage bitte in die nachfolgenden Felder Deinen Benutzernamen und Kennwort ein, um Dich einzuloggen.


  • Username:
  • Passwort:
  •  
  • Bei jedem Besuch automatisch einloggen.


  •  
   

falscher Link in E-Mail Benachrichtigung



robotto7831a versteckt
Benutzer
Avatar
Ort:  
Beiträge: 42 seit: 08 / 2006
Private Nachricht
Betreff: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 14.07.2014 - 16:37 Uhr  -  
Hallo zusammen,

wenn man Themen abonniert, dann erhält man bei der Antwort in dem Thread ja eine Mailbenachrichtigung.

Der Link in der Mail ist falsch.

Folgender Link steht z. B. in der Mail: http://www.onlinebanking-forum.de/forum/topic.php?t=1 7799&page=last#last_post

Man beachte das Leerzeichen zwischen t=1 und 7799. In der Mailanzeige wird der Link richtig dargestellt nur wenn man drauf klickt, dann landet man woanders.
Dieser Post wurde 1 mal bearbeitet. Letzte Editierung: 14.07.2014 - 16:38 Uhr von robotto7831a.
nach unten nach oben
Raimund Sichmann offline
Benutzer
Avatar
Ort:  
Beiträge: 7421 seit: 08 / 2002
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 14.07.2014 - 19:33 Uhr  -  
womit öffnest du die Mail?
Gruß
Raimund
nach unten nach oben
robotto7831a versteckt
Benutzer
Avatar
Ort:  
Beiträge: 42 seit: 08 / 2006
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 14.07.2014 - 19:41 Uhr  -  
Outlook 2013

Die Benachrichtigung gerade eben war OK.
nach unten nach oben
Heart offline
Benutzer
Avatar
Ort:  
Beiträge: 302 seit: 11 / 2003
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 15.07.2014 - 08:21 Uhr  -  
Habe das auch desöfteren (in 2 von 10 Fällen ca.) und schob dieses Phänomen bisher immer auf den Mail Client hier (Lotus Notes), aber wenn das auch in Outlook passiert...!?
Gruß
Hermann H.
nach unten nach oben
hibiscus offline
Benutzer
Avatar
Ort:   Leipzig
Beiträge: 5844 seit: 03 / 2005
Homepage Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 16.07.2014 - 09:04 Uhr  -  
Das scheint nicht Mail-Client-spezifisch zu sein. Ich hab das auch hin und wieder (mit einem Android-Mailclient). Ich hatte mir den Quelltext der betroffenen Mails auch mal angeschaut. Da steht tatsaechlich manchmal an willkuerlicher Stelle in der URL ein Leerzeichen drin. Hatte das vor einiger Zeit auch schonmal hier irgendwo geschrieben, finde das Posting aber nicht mehr. Ich halte das fuer einen Bug in der Foren-Software.
nach unten nach oben
DBuessen offline
Benutzer
Avatar
Ort:   Eckernförde
Beiträge: 1564 seit: 02 / 2011
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 16.07.2014 - 18:17 Uhr  -  
Moin hibiscus,
wenn ich da mal kurz aushelfen darf: topic.php?t=16580&page=fst_unread&highlight=leer

Vielleicht war es das, was Du gesucht hast? :-/
Gruß,
D. Büssen
WIN 7 (64bit) - WIN 10 (64bit)
nach unten nach oben
Raimund Sichmann offline
Benutzer
Avatar
Ort:  
Beiträge: 7421 seit: 08 / 2002
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 16.07.2014 - 19:57 Uhr  -  
Der Programmierer vermutete den Fehler an einem Fehler in der übernommenen Datenbank, allerdings hatte ich damals alle Vorschläge soweit durchgeführt.
Ich kann es mir nicht erklären, werde ich aber zur Sicherheit noch einmal machen.
Ich halte es für ein Bug, weil die Stelle nicht immer gleich ist.
Womöglich hängt immer hinter dem 1024sten Byte ein Leerzeichen drin.
Gruß
Raimund
das nervige ist: Bei mir kommt das ABo erst gar nicht an...
nach unten nach oben
robotto7831a versteckt
Benutzer
Avatar
Ort:  
Beiträge: 42 seit: 08 / 2006
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 16.07.2014 - 21:01 Uhr  -  
Was auch kurios ist, wenn man auf den Link klickt, dann soll man ja eigentlich auf den letzten Posting landen.

Ich lande immer auf den letzten Posting auf Seite 1 auch wenn der Thread drei oder mehr Seiten hat. Ich lande immer auf den letzten Beitrag auf Seite 1.
Dieser Post wurde 1 mal bearbeitet. Letzte Editierung: 16.07.2014 - 21:02 Uhr von robotto7831a.
nach unten nach oben
onlbanker offline
Benutzer
Avatar
Ort:  
Beiträge: 3335 seit: 05 / 2013
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 17.07.2014 - 07:55 Uhr  -  
robotto, das könnte mit dem E-Mail Client zusammenhängen, weil der vielleicht hinten das was hinter dem Lattenzaun # steht nicht an den Browser weiterreicht, das ist nämlich die Sprungmarke im Dokument. Zeig mal bitte so einen Link bei dem das passiert.
Dieser Post wurde 2 mal bearbeitet. Letzte Editierung: 17.07.2014 - 07:56 Uhr von onlbanker.
nach unten nach oben
Raimund Sichmann offline
Benutzer
Avatar
Ort:  
Beiträge: 7421 seit: 08 / 2002
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 17.07.2014 - 08:06 Uhr  -  
danke für deinen Post, jetzt ist die Mail auch bei mir angekommen.
das ist der Link aus dem Mailtext
Code

http://www.onlinebanking-forum.de/forum/topic.php?t=17812&page=last#last_post
und hier ist auch ein Leerzeichen im Link:
http://www.onlinebanking-forum.de/forum/topic.php?t=17812&pag%20e=last#last_post

Da ist auch klar, warum es nicht klappen kann, mit dem Sprung zur letzten Seite.
Gruß
Raimund
Dieser Post wurde 1 mal bearbeitet. Letzte Editierung: 17.07.2014 - 08:07 Uhr von Raimund Sichmann.
nach unten nach oben
robotto7831a versteckt
Benutzer
Avatar
Ort:  
Beiträge: 42 seit: 08 / 2006
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 17.07.2014 - 08:21 Uhr  -  
Genau. Dort hat sich auch ein Leerzeichen eingeschlichen.
nach unten nach oben
Raimund Sichmann offline
Benutzer
Avatar
Ort:  
Beiträge: 7421 seit: 08 / 2002
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 17.07.2014 - 08:26 Uhr  -  
Damit müsste ich eigentlich weiter kommen.
Gruß
Raimund
nach unten nach oben
hibiscus offline
Benutzer
Avatar
Ort:   Leipzig
Beiträge: 5844 seit: 03 / 2005
Homepage Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 17.07.2014 - 08:47 Uhr  -  
Zitat geschrieben von DBuessen

Vielleicht war es das, was Du gesucht hast? :-/


Genau das war's ;)
nach unten nach oben
hibiscus offline
Benutzer
Avatar
Ort:   Leipzig
Beiträge: 5844 seit: 03 / 2005
Homepage Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 17.07.2014 - 08:58 Uhr  -  
Zitat geschrieben von Raimund Sichmann


Wobei im eigentlichen Quelltext der Mail aber nicht das "%20" drin steht. Das ist die URL-codierte Form eines Leerzeichens. Das schreibt da erst der Browser rein, wenn man auf den Link klickt. Beim Uebernehmen der URL in der Adressleiste untersucht der die URL auf unerlaubte Zeichen und codiert die entsprechend.

Im eigentlichen Quelltext der Mail findet sich an der Stelle ein Zeilenumbruch, gefolgt von einem Leerzeichen. Der Zeilenumbruch wird vom Mailclient ignoriert (da es ja eine HTML-Mail ist), das Leerzeichen aber nicht. In dem HTML-Part ist nur genau ein Zeilenbumbruch enthalten - in meinem Fall hinter dem 984sten Zeichen. Die 1024er Grenze passt also auch nicht so ganz.

In der Mail findet sich uebrigens auch folgender Header:

Code

X-PHP-Originating-Script: 2044:class_email.php


Ich wuerde also mal dort schauen, ob sich der Mailversand von HTML auf Plain-Text umstellen laesst. Das wuerde die Problematik sicher loesen. Oder alternativ mal in der class_email.php schauen, ob die irgendwo Zeilenumbrueche einfuegt.
nach unten nach oben
onlbanker offline
Benutzer
Avatar
Ort:  
Beiträge: 3335 seit: 05 / 2013
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 18.07.2014 - 07:00 Uhr  -  
Olaf, du hast anstatt auf Bearbeiten auf "Zitieren" geklickt. Kannst du die Beiträge 15 und 14 noch löschen sonst würde ich einen Mod darum bitten?
Dieser Post wurde 1 mal bearbeitet. Letzte Editierung: 18.07.2014 - 07:00 Uhr von onlbanker.
nach unten nach oben
DBuessen offline
Benutzer
Avatar
Ort:   Eckernförde
Beiträge: 1564 seit: 02 / 2011
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 18.07.2014 - 07:52 Uhr  -  
Zitat geschrieben von onlbanker

Olaf, du hast anstatt auf Bearbeiten auf "Zitieren" geklickt. Kannst du die Beiträge 15 und 14 noch löschen sonst würde ich einen Mod darum bitten?


Moin onlbanker,

mit dem nachträglichem "Löschen" wird es wohl nichts.
Da wären wir gleich wieder bei diesem Thema: topic.php?t=16887 :-/

Die Regel mit den 3600 Sekunden ist immer noch nicht bereinigt??
Gruß,
D. Büssen
WIN 7 (64bit) - WIN 10 (64bit)
nach unten nach oben
Raimund Sichmann offline
Benutzer
Avatar
Ort:  
Beiträge: 7421 seit: 08 / 2002
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 18.07.2014 - 08:04 Uhr  -  
das sollte eigentlich wirklich erledigt sein, weil dies ja auch ein neuer Thread ist.
Ich hoffe, ich hab nichts falsches gelöscht. Mein UMTS_Provider cached die Seite, evtl. habe ich einmal zu viel geklickt...
Gruß
Raimund
nach unten nach oben
hibiscus offline
Benutzer
Avatar
Ort:   Leipzig
Beiträge: 5844 seit: 03 / 2005
Homepage Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 18.07.2014 - 08:52 Uhr  -  
Zitat geschrieben von Raimund Sichmann

Ich hoffe, ich hab nichts falsches gelöscht.


Danke fuer's Loeschen. Ich hatte nur falsch gequotet.
nach unten nach oben
onlbanker offline
Benutzer
Avatar
Ort:  
Beiträge: 3335 seit: 05 / 2013
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 18.07.2014 - 16:46 Uhr  -  
Zitat geschrieben von Raimund Sichmann
Mein UMTS_Provider cached die Seite

Manchmal gibt es vom Netzanbieter dafür Software, die diese sch.... zwangscaching ausschalten. Darüber hab ich mich auch schon mehr als einmal aufgeregt.
nach unten nach oben
Raimund Sichmann offline
Benutzer
Avatar
Ort:  
Beiträge: 7421 seit: 08 / 2002
Private Nachricht
Betreff: Re: falscher Link in E-Mail Benachrichtigung  -  Gepostet: 20.07.2014 - 12:54 Uhr  -  
Zitat geschrieben von hibiscus
Im eigentlichen Quelltext der Mail findet sich an der Stelle ein Zeilenumbruch, gefolgt von einem Leerzeichen. Der Zeilenumbruch wird vom Mailclient ignoriert (da es ja eine HTML-Mail ist), das Leerzeichen aber nicht. In dem HTML-Part ist nur genau ein Zeilenbumbruch enthalten - in meinem Fall hinter dem 984sten Zeichen. Die 1024er Grenze passt also auch nicht so ganz.

Da lag ich aber vermutlich nicht so ganz falsch:
http://stackoverflow.com/quest...ssage-text
Ich vermute sehr, dass es genau dieser "Effekt" ist.
Da ich eh die Mail-Texte angepasst hab, wanderte das Leerzeichen inzwischen in einen Bereich, wo es keinen Schaden anrichtet, ich lasse also erstmal den Quelltext so.
Gruß
Raimund
nach unten nach oben
 



Registrierte in diesem Topic
Aktuell kein registrierter in diesem Bereich

Cookies von diesem Forum entfernen  •  FAQ / Hilfe  •  Teamseite  •  Impressum   |  Aktuelle Ortszeit: 21.04.2018 - 15:16