schließen

Loginbox

Trage bitte in die nachfolgenden Felder Deinen Benutzernamen und Kennwort ein, um Dich einzuloggen.


  • Username:
  • Passwort:
  •  
  • Bei jedem Besuch automatisch einloggen.


  •  
   

USB Chipdrive micro 130 und 64 bit



olli0371 offline
Benutzer
Avatar
Ort:  
Beiträge: 4 seit: 10 / 2014
Private Nachricht
Betreff: USB Chipdrive micro 130 und 64 bit  -  Gepostet: 09.10.2014 - 12:30 Uhr  -  
Hallo,

ich musste meinen alten Rechner mit serieller Schnittstelle in Rente schicken. Dort hat mein Hibiscus immer einwandfrei funktioniert.

Nun benutze ich Version 2.6.9 von Hibiscus und habe nun noch einen USB-KArtenleser Chipdrive micro 130 hier. Früher lief er unter Ubuntu (welche Version weiß ich nicht mehr) und 32bit auch.

Hier bekomme ich beim KArtentest immer das hier:

09.10.2014 12:27:29] open ddv passport
[09.10.2014 12:27:29] jni lib: /home/spk/.jameica/plugins/hibiscus/lib/libhbci4java-card-linux-64.so
[09.10.2014 12:27:29] ctapi driver: /home/spk/.jameica/plugins/hibiscus/lib/libtowitoko-2.0.7-amd64.so
[09.10.2014 12:27:29] Fehler beim Testen des Sicherheits-Mediums: can not load ctapi lib /home/spk/.jameica/plugins/hibiscus/lib/libtowitoko-2.0.7-amd64.so - ret=0 response=00 00 (0000)
[09.10.2014 12:27:29] Aufgetretene Fehlermeldungen:
[09.10.2014 12:27:29] port: COM/USB [ID: 0]
[09.10.2014 12:27:29] -----------------------------
[09.10.2014 12:27:29] error while opening chipcard; nested exception is:
[09.10.2014 12:27:29] ctnumber: 0
[09.10.2014 12:27:29] Chipkarten-Fehler
[09.10.2014 12:27:29] Chipkarten-Fehler
[09.10.2014 12:27:29] soft pin: true
[09.10.2014 12:27:29] can not load ctapi lib /home/spk/.jameica/plugins/hibiscus/lib/libtowitoko-2.0.7-amd64.so - ret=0 response=00 00 (0000)
[09.10.2014 12:27:29] -----------------------------
[09.10.2014 12:27:29] entry index: 2
[09.10.2014 12:27:29] passport type: DDV
[09.10.2014 12:27:29] test of passport failed: class org.kapott.hbci.exceptions.CTException: can not load ctapi lib /home/spk/.jameica/plugins/hibiscus/lib/libtowitoko-2.0.7-amd64.so - ret=0 response=00 00 (0000)

Ich habe nu ndiverse Einträge gelesen und Benutzrechteproblem kann ich wohl ausschliessen. Zuerst hatte ich den Benutzer der Gruppe dialout zugefügt und dann das Ganze als Root laufen lassen (testweise). Geändert hat das nichts und ich weiß nun nicht mehr weiter. :'(

Ich hoffe, das jemand hier mir helfen kann.

(Ubunut 14.04 64 bit)

Edit: Ich habe nun die PCSC Tools und den Towitokotreiber aus den Ubunutquellen installiert. Eine Umstellung von Hibiscus auf PCSC bringt nun diese Meldung hier:

09.10.2014 13:02:08] Teste Sicherheits-Medium...
[09.10.2014 13:02:08] open ddv passport
[09.10.2014 13:02:08] pcsc name:
[09.10.2014 13:02:08] soft pin: false
[09.10.2014 13:02:08] entry index: 2
[09.10.2014 13:02:08] passport type: DDVPCSC
[09.10.2014 13:02:08] found card terminals:
[09.10.2014 13:02:08] Towitoko Chipdrive USB 00 00
[09.10.2014 13:02:09] card type: T=1
[09.10.2014 13:02:09] using: org.kapott.hbci.smartcardio.DDVCardService1
[09.10.2014 13:02:09] querying features
[09.10.2014 13:02:09] Fehler beim Testen des Sicherheits-Mediums: SCARD_E_INVALID_PARAMETER
[09.10.2014 13:02:09] Aufgetretene Fehlermeldungen:
[09.10.2014 13:02:09] -----------------------------
[09.10.2014 13:02:09] error while opening chipcard; nested exception is:
[09.10.2014 13:02:09] org.kapott.hbci.exceptions.HBCI_Exception
[09.10.2014 13:02:09] transmitControlCommand() failed
[09.10.2014 13:02:09] SCARD_E_INVALID_PARAMETER
[09.10.2014 13:02:09] -----------------------------

Der Leser wird angesprochen (rote LED an). Also ein kleiner Schritt weiter. (-;

Viele Grüße
Oliver
Dieser Post wurde 2 mal bearbeitet. Letzte Editierung: 09.10.2014 - 13:19 Uhr von olli0371.
nach unten nach oben
olli0371 offline
Benutzer
Avatar
Ort:  
Beiträge: 4 seit: 10 / 2014
Private Nachricht
Betreff: Re: USB Chipdrive micro 130 und 64 bit  -  Gepostet: 09.10.2014 - 15:18 Uhr  -  
So,

der USB-Kartenleser wird auch unter den PCSC Tools mit PCSC_SCAN erkannt. Karte einschieben und entfernen wird auch angezeigt. Die Treiber arbeiten demnach wohl.

Lediglich Hibiscus scheint so seine Probleme zu haben.
Die Fehlermeldung ist immer noch die gleiche wie oben.

Die Karte ist auch ok - ich habe sie erfolgrreich mit dem seriellen Kartenleser Chipdrive an einem anderen Rechner in Hibiscus testen können.


Noch jemand irgendwelche Ideen ?

Schöne Tage
Oliver
nach unten nach oben
olli0371 offline
Benutzer
Avatar
Ort:  
Beiträge: 4 seit: 10 / 2014
Private Nachricht
Betreff: Re: USB Chipdrive micro 130 und 64 bit  -  Gepostet: 09.10.2014 - 20:19 Uhr  -  
Hallo,

so hier nun auch die Lösung des Problemes. Ich konnte den USB-Kartenleser mit dem pcsc-ctapi-wrapper ans Laufen bekommen. Ist nicht optimal weil nach meinem Verständnis nun der Wrapper nur zwischen PCSC und CTAPI übersetzt aber es funktioniert nun.

Hilfreich war diese Anleitung hier:

http://www.willuhn.de/wiki/doku.php?id=support:list:kartenleser:pcsc:fedora

Ist zwar für Feodora, funktiniert aber auch bei Ubuntu 14.04.

Gruß
Oliver
nach unten nach oben
andreas0815 offline
Benutzer
Avatar
Ort:  
Beiträge: 2 seit: 09 / 2016
Private Nachricht
Betreff: Re: USB Chipdrive micro 130 und 64 bit  -  Gepostet: 14.09.2016 - 21:28 Uhr  -  
Hallo Olli.

Ich habe dieselben Erfahrungen mit dem Chipdrive Micro 130 gemacht, allerdings in umgekehrter Reihenfolge:

Bisher lief Hibiscus unter Ubuntu 14.04 64bit erfolreich mit dem Kartenleser in der Wrapper- Variante. Nach einem Update auf 16.04 klappt das leider nicht mehr. Der Autor von Hibiscus hat mich auf die PCSC- Variante verwiesen, die aber genau wie bei dir mit exakt denselben Meldungen wie in deinem Post hier beschrieben scheitert.
Meine Frage deshalb: Hast du ev. ebenfalls auf 16.04 gewechselt und bessere Erfahrungen gemacht? Hast du ev. die PCSC-Variante inzwischen zum Laufen gebracht?

Grüße, Andreas
nach unten nach oben
olli0371 offline
Benutzer
Avatar
Ort:  
Beiträge: 4 seit: 10 / 2014
Private Nachricht
Betreff: Re: USB Chipdrive micro 130 und 64 bit  -  Gepostet: 06.01.2017 - 21:35 Uhr  -  
Hallo Andreas,

auch wenn dein Post schon lange her ist - ich hatte bis gestern nicht auf 16.04 umgestellt und alles funktionierte wie es soll. Nun stehe ich auch vor diesem Problem und bekomme das Sch- Ding nicht ans laufen. Ich habe nun den gestrigen Abend damit verbracht zu versuchen das Teil unter ubuntu 16.04 ans laufen zu bekommen - bisher ohne Erfolg.
Ich werde das Teil wohl beerdigen und einen neuen Kartenleser kaufen.

Hibiscus kommt mit dem Teil einfach nicht klar.

Gruß
Oliver
nach unten nach oben
hibiscus offline
Benutzer
Avatar
Ort:   Leipzig
Beiträge: 5540 seit: 03 / 2005
Homepage Private Nachricht
Betreff: Re: USB Chipdrive micro 130 und 64 bit  -  Gepostet: 09.01.2017 - 09:25 Uhr  -  
Dieser Kartenleser ist zugegebenermaßen aber auch ein steinaltes Gerät. Der hat ja noch nicht mal ein Pin-Pad, was eigentlich schon lange eines Mindest-Anforderung sein sollte.
nach unten nach oben
andreas0815 offline
Benutzer
Avatar
Ort:  
Beiträge: 2 seit: 09 / 2016
Private Nachricht
Betreff: Re: USB Chipdrive micro 130 und 64 bit  -  Gepostet: 20.03.2017 - 18:54 Uhr  -  
Ich nutze jetzt eine VM in VirtualBox mit Windows XP 32Bit. Darin funktioniert Hibiscus mit dem Chipdrive 130 ohne Probleme. Ist nicht schön aber für 3-4 mal Onlinebanking im Monat reicht es.
nach unten nach oben
hibiscus offline
Benutzer
Avatar
Ort:   Leipzig
Beiträge: 5540 seit: 03 / 2005
Homepage Private Nachricht
Betreff: Re: USB Chipdrive micro 130 und 64 bit  -  Gepostet: 20.03.2017 - 19:26 Uhr  -  
Windows XP? Ehrlich. Wechsle lieber auf ein modernes TAN-Verfahren auf einem aktuellen OS. Weder der Kartenleser noch XP kann man auch nur annähernd als zeitgemäß oder sicher bezeichnen.
nach unten nach oben
 



Registrierte in diesem Topic
Aktuell kein registrierter in diesem Bereich

Cookies von diesem Forum entfernen  •  FAQ / Hilfe  •  Teamseite  •  Impressum   |  Aktuelle Ortszeit: 25.05.2017 - 01:26